Поле объекта недоступно для записи номер

При первых начинания неопытных разработчиков 1С 8.3 достаточно часто возникает такая проблема: Поле объекта недоступно для записи 1С. Необходимо разобраться, почему же может возникать подобная проблемы и что следует делать, чтобы она больше не беспокоила пользователя. В случае если вы НЕ программист 1С, а обычный пользователь. Если программирование для вас всего лишь обычное слово и к нему вы не имеете никакого отношения, то лучше ничего не трогать, так как вы можете ещё больше усугубить ситуацию.

Возможно, проблема заключается в обычной ошибке, которую допустил ваш программист при доработке конфигурации. В таком случае, вам просто необходимо попросить помощи у специалиста, который разберется в данной ситуации без каких-либо проблем.

Автор Тема: Поле объекта недоступно для записи (Номер строки) (Прочитано 18133 раз). 0 Пользователей и 1. Контрагент = Справочники.Контрагенты.НайтиПоНаименованию(Структура.контрагент); ДокРасчетов. Можно использовать какую-то функцию 1С, чтобы номер заполнялся? МодульОбъекта(166)}: Поле объекта недоступно для записи (Формы) Формы = ЭтотОбъект.Метаданные().Формы; ТУТ: Код: // ЭКСПОРТИРУЕМЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ Процедура вЗагрузитьОбработки(ДоступныеОбработки, ВыбранныеОбработки) Экспорт Формы = ЭтотОбъект. Поместил кнопку в форме списка справочника, написал код: Процедура ДействияФормыНомера(Кнопка) Выборка = Справочники.СписокУпражнений.Выбрать(); Пока Выборка.Следующий() Цикл Если Выборка.Родитель.Наименование = » Тогда Если Выборка.ГруппаМышц.

Подобная ошибка легко исправляется, если она не успела потянуть за собой осложнения. Также можно обновить полностью платформу до новейшей версии, если проблема «поле объекта недоступно для записи 1С» появилась после недавнего обновления конфигурации. Полезная информация для начинающих программистов 1С. Наиболее частой ошибкой неопытных программистов является изменение в программном коде данных, которые менять у вас не было права.

Для подробного разъяснения, необходимо рассмотреть следующие ситуации: Следует менять объект, а не ссылку! Самым распространенным объяснением появления данной ошибки следует считать изменение свойств ссылки, а не объекта. Как правило, это выглядит так: Сидоров = Справочник.ФизЛицо.ПоискПоНаименованию(«Сидоров Федор»); Сидоров.НомерУдостоверенияЛичности = «6574928»; В таком случае и возникает проблема «Поле объекта недоступно для записи 1С». Нужно запомнить, что возможность менять реквизиты или какие-либо свойства характерна только объекту. В приведенном примере переменная «Сидоров» включает в себя идентификатор для поддержки уникальности в базе, то есть ссылку. Верный вариант: СидоровСсылка = Справочник.ФизЛицо.ПоискПоНаименованию («Сидоров Федор»); СидоровОбъект = СидоровСсылка.ПолучитьОбъект(); СидоровОбъект.

Вот еще: вот решил попробовать замену значений в справочнике в табличной части, надо отобрать и просто удалить значение (заменить на пустое) и вот после отбора: «»{Форма.ПодборИОбработка.Форма(991)}: Ошибка при вызове метода контекста (Вывести): Ошибка вывода результата: Ошибка при выводе результата: Ошибка получения данных: Ошибка создания набора данных «»НаборДанныхЗапроса»»: Ошибка при исполнении запроса набора данных: {(223, 31)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля неограниченной длины и поля несовместимых типов. ТаблицаСсылок.Ссылка.Рационы >= &П»».

Похожие темы Тема Автор Форум Ответов Посл. Сообщение Важная: Обработка (управляемое и обычное приложение, обмен данными УТ 10.3/10.2 — БП 3.0) Предназначена для переноса документов и справочников из базы УТ 10.3/УТ 10.2 в базу БП 3.0 без использования планов обмена.:arrow: Поддерживаемые релизы (для платформ 1С Предприятия 8.1, 8.2, 8.3): Управление торговлей: 79 Сб 09 Сен, 2017 00:22 Обработка (управляемое приложение) Позволяет упростить процесс отладки и тестирования внешних обработок заполнения, в том числе табличных частей, или создания связанных объектов (ввода на основании) для конфигураций 1С: Предприятия 8.2/8.3, разработанных 39 Вт 18 Апр, 2017 19:43 Обработка (управляемое и обычное приложение) Предназначена для просмотра/изменения ролей (прав доступа) пользователей информационной базы как в режиме управляемого, так и обычного приложения без привязки к конкретной конфигурации. Для группового изменения ролей 8 Чт 02 Фев, 2017 19:45 Обработка (управляемое и обычное приложение), обмен данными Назначение: универсальная обработка для регистрации, отмены регистрации изменений (управления регистрацией) в планах обменов, мониторинга состояния обмена данными как в режиме управляемого, так и обычного приложения без 28 Пт 18 Авг, 2017 01:06 Универсальный механизм контроля заполнения реквизитов объектов в режиме предприятия (обычное приложе Универсальный механизм контроля заполнения реквизитов (контроль незаполненных реквизитов) шапки и табличных частей объектов конфигурации (справочников, документов, бизнес-процессов, задач, планов обмена, планов видов 15 Чт 09 Июл, 2015 15:29.

Поместил кнопку в форме списка справочника, написал код: Процедура ДействияФормыНомера(Кнопка) Выборка = Справочники.СписокУпражнений.Выбрать(); Пока Выборка.Следующий() Цикл Если Выборка.Родитель.Наименование = «» Тогда Если Выборка.ГруппаМышц. 14 окт 10, 17:20 Ответить| Цитировать Сообщить модератору. Re: Поле объекта недоступно для записи. 1c8.2 Справочник Сотрудники Модуль формы элемента. Процедура ПриОткрытии() Если не ЭтоНовый() Тогда.

При работе с 1С довольно часто может появляться сообщение об ошибке » Поле объекта недоступно для записи». Рассмотрим, какие действия могут привести к ней, и как её можно устранить. Причины возникновения ошибки К появлению системного окна с этой ошибкой может привести 6 факторов: Попытка изменения значений в полях, смена которых бессмысленна; Ошибка в коде; Попытка изменения системных полей; Недостаточно прав на изменение; Устаревшая конфигурация 1С; В управляемой форме используется элемент и реквизит с одним именем.

Попытка изменения значений в полях, смена которых бессмысленна Например, в программе происходит попытка замены ссылки, а не объекта. Но сделать этого невозможно. Если изменить ссылку, то, во-первых, она будет ссылаться на несуществующий объект (в никуда), во-вторых, нужный объект по ней вы больше не найдёте. Пример неправильного фрагмента кода: Иванов = Справочники.ФизическиеЛица.НайтиПоНаименованию(«Иванов Петр»); Иванов.НомерПаспорта = «2175353»; И при вводе последней строчки появляется ошибка «Поле объекта недоступно для записи». Причина в том, что происходит попытка редактирования свойств или реквизитов ссылки. В указанном примере параметру «НомерПаспорта» вы пытаетесь задать определённое значение. Но эти данные можно менять только у объекта.

В данном примере «Иванов» — это именно ссылка, которая предназначена для чтения. По ней человек идентифицируется в базе данных. Во второй строчке указана «точка» — «Иванов.НомерПаспорта». Но это также не объект, потому что при обращении к «точке» выполняется все тот же запрос к базе данных. Сделано это для удобства использования 1С. Как исправить ошибку?

Чтобы сообщение » Поле объекта недоступно для записи» больше не появлялось, нужно прописать следующее: ИвановСсылка = Справочники.ФизическиеЛица.НайтиПоНаименованию(«Иванов Петр»); ИвановОбъект = ИвановСсылка.ПолучитьОбъект(); ИвановОбъект.НомерПаспорта = «2175353»; ИвановОбъект.Записать(); Теперь по ссылке выполняется обращение к объекту, а затем уже он редактируется. После этого объект записывается, то есть фиксируется его новое состояние. Ошибка в коде Возможно причина в том, что программист, который работал с текущей конфигурацией 1С, допустил ошибку при доработке. Тогда исправить её сможет также только специалист. Желательно, чтобы это был именно тот человек, который изначально настраивал 1С.

Попытка изменения системных полей Пользователь пытается редактировать те данные, на замену которых он не имеет прав. Например, номер строки в таблице, установка «ТекущаяСтрока» вместо «ТекущиеДанные» и т. Иногда ошибка возникает из-за простой невнимательности. Если обращаться к правильным полям – ошибка появляться не будет. Недостаточно прав на изменение Иногда поле, которое пытается изменить пользователь, доступно только для чтения. Это связано с правами на объекты конкретного пользователя. Чтобы устранить возникающую ошибку, необходимо проанализировать права на конкретный объект и либо разрешить пользователю доступ к соответствующему полю (на запись), либо вообще исключить поле (или целый объект) из рассмотрения.

Устаревшая конфигурация 1С Иногда ошибка » Поле объекта недоступно для записи» появляется при обновлении 1С. Чтобы убрать её, нужно обновиться до самой свежей версии платформы. Устранить ошибку обычно не сложно и сделать это может сам пользователь. Если же серьёзно нарушена конфигурация 1С, исправить положение сможет только специалист. В управляемой форме используется элемент и реквизит с одним именем Достаточно редко ошибка » Поле объекта недоступно для записи» появляется при совпадении имён реквизита и элемента управляемой формы.

Чтобы устранить ошибку, необходимо явно прописать обращение к реквизиту или элементу формы. К примеру, в форме 1С имеется реквизит с именем «Сумма».

С таким же именем на форме находится элемент «Сумма».

После обновления конфигурации 1С:Предприятие столкнулся со следующей проблемой. При вызове списка пользователей возникает ошибка Полный текст ошибки выглядит так {Обработка.СписокПользователейИБ.МодульОбъекта(35)}: Поле объекта недоступно для записи (Пользователи) Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей(); Причем, возникала данная ошибка только у пользователей с полными правами в базе. Источником проблемы оказалось то, что в переменная Пользователи зарезервирована в последних версиях. Решение простое, в процедуре нужно поменять имя переменной с Пользователи на другое, например Пользователи1 Процедура ЗаполнитьСписокПользователейИБ(ОтборСтрок) Экспорт ТабличнаяЧастьПользователей.Очистить(); Пользователи1 = ПользователиИнформационнойБазы.ПолучитьПользователей(); Для Каждого Пользователь Из Пользователи1 Цикл.

Доброго времени суток. Я добавил в БП 3.0 свои роли. В документе РеализацияТоваровУслуг (в моей роли для него установлены все права) есть гиперссылка «»НДС в сумме (сверху)»». Она вызывает общую форму ФормаЦеныИВалюта (в моей роли и для нее установлено право — единственный пункт «»Просмотр»»). На форме 2 поля — Тип цен (оно почему-то только для чтения, хотя с полными правами доступно) и НДС.

При изменении поля НДС появляется следующая ошибка: {ОбщаяФорма.ФормаЦеныИВалюта.Форма(525)}: Поле объекта недоступно для записи (СуммаВключаетНДС) СуммаВключаетНДС = Ложь; СуммаВключаетНДС — это реквизит формы, если открыть его свойство «»Редактирование»», то там есть моя роль. Я провел сравнение с типовой конфигурацией — различий нет. Значит дело в роли. Чего в ней не хватает? Добавлено через 23 часа 58 минут Ап! И откуда только у меня такие проблемы берутся?

Ошибка: «Значение не является значением объектного типа (ПравоеЗначение)» в 1С:Бухгалтерия 8.3. Ошибка при попытке изменить учетную политику «Объект не найден». Иванов = Справочники.ФизическиеЛица.НайтиПоНаименованию(«Иванов Петр»). Иванов.НомерПаспорта = «2175353». И при вводе последней строчки появляется ошибка «Поле объекта недоступно для записи». Причина в том, что происходит попытка редактирования свойств. В итоге, в режиме 1с предприятие выдает ошибку: {Справочник.СписокУпражнений.Форма.СписокУпражнений(7)}: Поле объекта недоступно для записи (Родитель) Выборка.Родитель = «Грудь».

Я подобрал для вас темы с ответами на вопрос 1C 8.x БП 3.0. Ошибка «»Поле объекта недоступно для записи»» (1С): 1c8.2 Справочник Сотрудники Модуль формы элемента Добавил Новыйреквизит Справочника. При добавлении в модуле строки: выдает. При выполнении функции появляется ошибка про недоступность записи для контрагента при этом все равно записывает значение. Здравствуйте, есть обработка для выгрузки данных из Экселя в табличную часть любого документа (см. Пытаюсь выгрузить данные. Помогите решить проблему.

При нажатии на печать сметы выдает ошибку {Документ.Смета.Команда.ПечатьСметы.МодульКоманды(18)}. Для заданого 0. Аналогичная проблема. Создаю новую роль копированием из «»ДобавлениеИзменениеДанныхБухгалтерии»». Ничего в ней не меняю, кроме названия!!!

Ставлю пользователю. Возникает ситуация, как у автора темы — та же самая ошибка вылезает, изменить входимость НДС в сумму никак. Создается впечатление, что возможность изменения этого поля где-то завязана именно на имя роли. Не могу найти где!!! И что все же делать в данной ситуации?

Полные права пользователю давать нельзя. Если же пользователю поставить любую другую роль, кроме «»ДобавлениеИзменениеДанныхБухгалтерии»» и «»ПолныеПрава»», даже если в них все права проставить, поле объекта недоступно. Конфигурация стандартная 1С Бухгалтерия, версия 3.0.40.31, находится на техподдержке с возможностью изменения. Из изменений как раз новые роли пытаемся создавать.

Цель — дать пользователю доступ только к отдельным видам документов и закрыть доступ к большинству справочников. Новые роли создавали копированием из роли «»ДобавлениеИзменениеДанныхБухгалтерии»». В режиме «»Предприятие»» пользователю устанавливаются права по профилю «»Только просмотр»». Затем редактируем в конфигураторе. Если проставить галочку на стандартной роли — все работает. Если снять галочку со стандартной роли и поставить на ее «»клоне»» — нет доступа к изменению входимости НДС. Та же картина, если роль создавать копированием роли «»ПолныеПрава»».

В «»клонированных»» ролях пока никаких изменений не делали! Файл конфигурации весит 450 метров.

Вот еще темы с ответами: Если очень хочется, но не хочется засорять тематические посты — СЮДА! Тэг OFF в данной теме означает «По теме» Для документа «ПродажаТоваров» на форму списка добавить «ПолеВвода» с типом «СправочникСсылка.Контрагенты». На событие формы «ПриОткрытии». Всем добрый день!

Нужна помощь. В Форму элемента «Номенклатура» нужно добавить два поля с выводом остатка и текущей цены в рознице. Есть ли готовое решение, можно через внешнюю форму нужно контроль «Текущая цена розницы» и «Остаток» товаров на складе. Или воспользуйтесь поиском по форуму.

Для начинающих разработчиков 1С 8.3 трудно понять, почему же они так часто получают ошибку — Поле объекта недоступно для записи 1С (РабочаяДата, Код, Таблица, Номер, Дата и т.д.) . Разберемся, почему эта ошибка может появятся, и как с ней бороться.

Если Вы понятия не имеете, что такое программирование, то лучше ничего не трогать. Скорее всего, программисты, которые дорабатывали Вашу конфигурацию, просто допустили досадную ошибку. Просто вызовите специалиста, который работал с Вами. Данная ошибка решается достаточно быстро (если она не тянет за собой другие, более сложные проблемы). Если контакты с личными программистами потеряны, Вы можете обратиться к нашим высококвалифицированным профессионалам, подробности на странице — .

Если ошибка возникла после обновления конфигурации 1С 8.2 или 8.3 , скорее всего, Вам необходимо до последней актуальной версии.

Получите 267 видеоуроков по 1С бесплатно:

Если Вы начинающий программист 1С

Если говорить в общем, то Вы пытаетесь в программном коде изменить данные, которые не имеете права менять. Рассмотрим конкретные случаи:

Меняй объект, а не ссылку

Хит-парад причин появления этой ошибки возглавляет попытка присвоения ссылке элемента новых атрибутов. Делают это обычно примерно так:

Петров = Справочники. ФизическиеЛица. НайтиПоНаименованию(«Петров Иван» ) ; Петров. НомерПаспорта = «2156363» ;

И вот на этом моменте новичок получает ошибку — Поле объекта недоступно для записи 1С.

Следует уяснить: изменять свойства и реквизиты возможно только объекта. В данном случае переменная «Петров» содержит в себе т.н. «ссылку» — уникальный идентификатор в базе данных, с помощью которого система поддерживает уникальность. А то, что нам доступно «по точке» (Петров.НомерПаспорта), — это просто удобство 1С предприятия, и на самом деле любая «точка» — это еще один запрос к базе данных.

Правильное решение задачи:

Попытка изменить системные поля

Второй по популярности причиной возникновения данной ошибки является попытка изменить реквизиты, которые не поддаются изменению.

  • номер строки табличной части;
  • использование ТекущаяСтрока, вместо ТекущиеДанные;
  • и так далее.

Код 1C v 8.х //Проверка на заполненность реквизитов формы, для которых установлен признак АвтоОтметкаНезаполненного
Функция ПроверкаАвтоОтметкаНезаполненного(ЭлементыФормы) Экспорт
Результат = Ложь;
Для каждого Элемент Из ЭлементыФормы Цикл
Если ТипЗнч(Элемент) = Тип(«ПолеВвода») Тогда
Если Элемент.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Элемент.Значение) Тогда
Сообщить(«Необходимо заполнить обязательное поле ввода: » + Элемент.Подсказка, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;
ИначеЕсли ТипЗнч(Элемент) = Тип(«ТабличноеПоле») Тогда
СоставПоля = Элемент.Значение;
Колонки = Элемент.Колонки;
Попытка // для ДокументСписок вызовет исключение
Для каждого Строка Из СоставПоля Цикл
Для каждого Колонка Из Колонки Цикл
Если ТипЗнч(Колонка.ЭлементУправления) = Тип(«ПолеВвода») Тогда
Если Колонка.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Строка) Тогда
Сообщить(«Необходимо заполнить обязательное поле ввода табличной части: » + Колонка.ТекстШапки, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Исключение
КонецПопытки;
КонецЕсли;
КонецЦикла;
Возврат Результат;
КонецФункции
Информация взята с сайта http://helpf.pro