Значение булево в 1С

булево — что это за фрукт? 1с8

Я learn_

тип — булево ? что это?

butterbean Булево (Boolean)Описание:
Значения данного типа имеют два значения Истина и Ложь, задаваемых соответствующими литералами.
Значения данного типа возвращаются в качестве результата вычисления логических выражений.
Литералы:
Истина (True) Ложь (False) almar

это ананас

Живой Ископаемый

первый раз вижу человека который умеет печатать но не умеет читать…

tsr

Пипец…. Девушка, а вы читать то пробовали, что вам посоветовали?

and2

(3) есть еще люди которые летать умеют :).

Megas Вот они киевские Программистыпрограммист
Достижения (опыт) 0,5лет Роль на форуме Зарегистрированный участник Дата регистрации: 09.07.2007Стаж: 1 г. 4 мес. learn_

да вы просто мне завидуете!

Shadd

(7) Фотку в студию!

Zlodey1С

а что означает Достижения (опыт) 0,5лет

Megas

Угу
Когда я пошёл в 5-ый класс я тоже незнал что такое булево, вот время то было !
А потом злобный препод по информатике ввёл у нас qbasic !

Hitcher

Чего-то у автора все вопросы не от мира сего: «Что такое компоновка, что такое булево». И где это она себе такие вопросы находит? Такое ощущение, что она взялась изучать 1С не с той стороны.

vde69

Модератор

не флудим

learn_

спасибо модератору….

Черный всадник

(0) http://ru.wikipedia.org/wiki/Булева_алгебра

Ненавижу 1С

Логический тип

Ненавижу 1С ks_83

Жэсть.

Функции преобразования значений

Булево (<Значение>) &#8213; преобразует полученный параметр в значение типа Булево.

Преобразование числа к типу Булево производится по следующим правилам:

· 0 преобразуется в Ложь;

· остальные значения преобразуются в Истина.

Дата (<Значение>) &#8213; преобразует полученный параметр (параметры) в значение типа Дата.

Допускаются следующие форматы задания параметров:

· Дата (Год, Месяц, День);

· Дата (Год, Месяц, День, Час, Минута, Секунда).

Пример.Дата (“19840329202101”);

Дата (“1984, 03, 29, 20, 21, 01”);

Строка (<Значение>) &#8213; преобразует полученный параметр в значение типа Строка.

При преобразовании к строке число формируется его полное представление в стандартном виде, соответствующем национальным установкам.

Число (<Значение>) &#8213; преобразует полученный параметр в значение типа Число.

Значение типа Строка преобразуется в число, если строка представляет собой из себя правильное строковое представление литерала численного типа. В противном случае будет выдано сообщение об ошибке выполнения функции.

Значение типа Булево преобразуется в число по следующим правилам:

· Ложь преобразуется в 0;

· Истина преобразуется в 1.

Функции форматирования

Формат (<Значение>, <Форматная строка>) &#8213; формирует удобное для чтения представление значений.

Прочие

Вычислить (<Значение>) &#8213; вычисляет переданное выражение.

1C Предприятие 8.1. Торговля. Булево

С помощью метода можно вычислять математические и логические выражения, а также операции конкатенации.

Пример.А = Вычислить (“500 + 500*20/100”);

ВычиИнформацияОбОшибке ()&#8213; получает структурированную информацию об исключении.

Макс (<Знач 1>, …, <Знач N>)&#8213; определяет максимальное значение из полученных параметров.

Мин (<Знач 1>, …, <Знач N>)&#8213; определяет минимальное значение из полученных параметров.

ОписаниеОшибки ()&#8213; получает описание ошибки.

Тип (<Имя типа>)&#8213; получает тип по его строковому имени.

ТипЗн (<Значение>)&#8213; получает тип значения.

МЕТОДИЧЕСКИЕ УКАЗАНИЯ:

1. Функции и процедуры должны содержаться в модуле объекта конфигурации (например, справочника).

2. Глобальная функции объявляется с помощью слова экспорт и размещается в ветви Общие модули дерева Конфигурации. Вызов глобальной функции производиться следующим образом: <Имя общего модуля>.<Имя функции>.

3. Для уточнения синтаксиса функций встроенного языка используется Синтаксис помощник на Стандартной панели инструментов.

СОДЕРЖАНИЕ РАБОТЫ:

1. Изучить и пояснить структуру основных процедур и функций.

2. Написать глобальную функцию с параметрами для расчета суммы чисел, передающихся в качестве параметров.

3. Написать процедуру для расчета произведения чисел от N до 10*N, где N — номер по журналу.

ВОПРОСЫ ВЫХОДНОГО КОНТРОЛЯ:

  1. Опишите особенности типа Дата.
  2. Опишите структуру процедуры, ее параметры, принцип работы.
  3. Объясните особенности структуры функции, принцип ее работы.
  4. Опишите структуру обработчика ДобавитьОбработчик.
  5. Опишите структуру обработчика УдалитьОбработчик.
  6. Дайте понятие передачи параметров в процедурах и функциях, особенности передачи данных по значению.
  7. Опишите работу с коллекциями.
  8. Опишите возможность использования номеров и индексов.
  9. Опишите работу с системными перечислениями.
  10. Перечислите функции работы со значениями типа Строка.
  11. Перечислите функции работы со значениями типа Число.
  12. Перечислите функции работы со значениями типа Дата.

ДОМАШНЕЕ ЗАДАНИЕ:

Выучить структуру процедуры и функции; добавления и удаления обработки; возможности передачи параметров в процедурах и функциях; возможность использования номеров и индексов; функции работы со значениями типа Строки, Число, Дата.

Если пишт «Преобразование значения к типу булево\число не может быть выполнено»

Довольно часто возникающая ошибка «преобразование значения к типу булево\число не может быть выполнено» на самом деле практически всегда легко поддается устранению.
Первое, что нужно сделать, если вы работаете с типовой конфигурацией системы 1С — это обновить конфигурацию до последнего релиза. Возможно, это решит проблему.
Но в большинстве случаев появление такой ошибки говорит попытке присвоить числовой переменной не численное значение, в результате внутренний конвертер типов не может преобразовать переменную в число и возникает ошибка.
Если присваивание переменной происходит из тела выборки результата запроса, следует проверить наличие в выборке значений типа NULL. Это значение недопустимо использовать в операциях с числами.
Значение NULL появляется в запросе при использовании соединений.
К примеру:
Сумма=КолВо*Выборка.Цена;
В этом случае ошибка возможна, если в регистре сведений цены номенклатуры нет записи по этой номенклатуре.
Решить проблему можно таким способом: во время обращения к полю выборки необходимо добавить проверку на равенство значению типа NULL. Либо использовать функцию ЕСТЬNULL(x1,x2). Она проверяет на NULL x1, и если Значение NULL обнаружено функция возвращает x2, в обратно случае возвращает x1.
В первом случае равенства Выражения1 NULL, Выражение1 будет заменено в результате запроса на заданное Выражение2.
Появление ошибки возможно в случае работы с Excel через COM соединение. Тогда необходимо проанализировать структуру книги Excel, на наличие значений NULL, и проверить, задан ли для искомых ячеек нужный тип данных. Либо значение ячейки присваивать числовой переменной через функцию преобразования типов «Число()» и после обращаться к ячейке внутри контейнера Попытка Исключение КонецПопытки.
В остальных случаях требуется работа с отладчиком для поиска ошибок, либо принудительное или непринудительное преобразование типов.

Значение Булево 1С — это значение Истина или Ложь. В числовом выражении Ложь это ноль, а Истина — число больше нуля (обычно единица).

Выражение (операция) Булево 1С — это математическое выражение, результатов которого является значение типа Булево 1С, например:
a = 0+1;
b = 2-1;
x = (a = b);
//x = Истина

Далее — подробнее о условных операциях 1С, значениях и выражениях булево 1С.

Условная операция 1С ЕСЛИ выглядит следующим образом:
Если ОПЕРАЦИЯ-БУЛЕВО Тогда
//действия1…
ИначеЕсли ОПЕРАЦИЯ-БУЛЕВО Тогда
//действия2…
Иначе
//действия3…
КонецЕсли;

Булево 1С — это результат вычисления со значениями Истина или Ложь, например:
Массив1 = Новый СписокЗначений();
Если Массив1.Количество() > 0 Тогда
//действия…
КонецЕсли;

//другой вариант, полностью аналогичный
Если НЕ Массив1.Количество() = 0 Тогда
//действия…
КонецЕсли;

Многие функции/методы объектов возвращают успешность выполнения операции как булево 1С, например:
Запрос = Новый Запрос();
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
//действия…
КонецЕсли;

В условной операции 1С можно объединять несколько условий с использованием И и ИЛИ:
Массив1 = Новый СписокЗначений();
Если (Массив1.Количество() > 0 и Массив1.Количество() 100 Тогда
//действия…
КонецЕсли;

Условия булево 1С можно использовать непосредственно в коде программы:
Переменная1 = 5;
флгРезультат = (Переменная1 = 2 + 3); //флгРезультат будет равен ИСТИНА

В условной операции 1С оператор ЕСЛИ ИНАЧЕ ТОГДА можно заменить более кратким выражением. Следующие два варианта равны:

Только зарегистрированные пользователи VIP группы могут видеть этот контент.

У реквизитов объектов (справочников, документов и т.п.) есть возможность установить тип булево 1С. Также можно создать переменную булево 1С, например:
флгВыполнено = Истина;

Далее, в условиях ЕСЛИ, можно писать равнозначно двумя способами:
//вариант 1
Если флгВыполнено = Истина Тогда
//делаем что-то
КонецЕсли;

//вариант 2
Если флгВыполнено Тогда
//делаем что-то
КонецЕсли;

Второй вариант таит в себе следующую «неприятность»:

Только зарегистрированные пользователи VIP группы могут видеть этот контент.